Chapter 2.  Interactive network

Start Interactive Mode

In the network view, we provide an "interactive" mode of the network where you can move the nodes just dragging them with the mouse. The interactive mode provides also other interesting features, such as automatic Layout and clustering (see below).

In order to use the interactive network you need to have flash player 10 installed on your computer. If you have not already installed the player you can do it from http://get.adobe.com/flashplayer/ . Just click on the 'interactive' button to start the interactive mode.

Once started, the interactive network appears exactly like the normal network except the small menu that you see at the top (see figure above).

Menu

From the menu on the top you can play with many useful features of the interactive network

File

Clicking on 'File->Save' you can export an image of the network to your computer.

Layout

Clicking on 'Layout->Relax->Start Relaxation' you can start an an automatic force-directed layout algorithm that orders the nodes in the network. The algorithm works iteratively trying to position the nodes apart from each other with a "preferred distance" proportional to the String global score.
'Right click on a node -> fix' in order to fix the node at the current position.

Clustering

From the 'Clustering' menu it is possible to launch 2 different clustering algorithms (KMEANS and MCL) to cluster the proteins that you are displaying in the network.

The only input to these clustering algorithms is the distance matrix obtained from the String global scores (so interacting proteins with an higher global score have more chances to end up in the same cluster).
Besides the distance matrix, both the algorithms accept 1 parameter as input:
- KMEANS accepts a parameter to specify the number of clusters that you want to obtain.
- MCL accepts a parameter called "inflation" that it is also indirectly related with the precision of the clustering (higher the inflation -> more clusters you obtain).

In order to launch the clustering, just click on the algorithm you want to launch (e.g. 'MCL').
A little panel with a slide-bar will appear below the menu.

You can move the slider in order to start the clustering with the right parameter value (after having moved the slider just wait few seconds for the clustering to complete).
As soon as the cluster completes, you will see the following differences in the network:
1) The color of the nodes has changed (i.e. every color corresponds to a cluster)
2) Inter-cluster edges are represented by dashed-lines
3) If you activate the 'Layout -> Relaxation' you will see clusters moving far away from each other (i.e. the nodes in a cluster are kept close from each other, but far away from the nodes of every other cluster )

IMPORTANT NOTE:
We will soon improve our clustering tools adding other algorithms suitable to cluster protein-protein interactions.
By now, we suggest you to use the MCL algorithm (see review paper below).
Please, note that if your network is small (i.e. it contains few nodes) the MCL algorithm will produce only a single large cluster. In that case, you could simply enlarge the network (e.g. clicking the '+' button or modifying the String parameters at the bottom of the page) and relaunch the clustering.

References:
- http://www.micans.org/mcl/ (MCL implementation)
- http://bonsai.ims.u-tokyo.ac.jp/~mdehoon/software/cluster/software.htm (KMEANS implementation)
- review paper: Evaluation of clustering algorithms for protein-protein interaction networks, Sylvain Brohée and Jacquesvan Helden, BMC Bionformatics 2006

Options

You can click on 'Options->Background-> Add background image' in order to add a background image of your choice to the interactive network.